ksaitoの日記

日々試したことの覚え書き

EOLのUbuntuをアップグレードする

取り残されていたUbuntu 9.04をアップグレードしようと思いましたが、EOFでアップグレードできませんでした。

$ sudo do-release-upgrade
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade toolmin 30s
Done downloading
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'
tar: メンバ名から先頭の `/' を取り除きます
 
キャッシュを読み込み中です
 
パッケージ・マネージャをチェック中です
 
アップグレードできません
 
An upgrade from 'jaunty' to 'lucid' is not supported with this tool.
 
$

仕方ないので、手動でaptリポジトリを切り替えてアップグレードしました。
もともとold-releases.ubuntu.comでしのいでいたので以下のように修正しapt-get update & apt-get upgradeしました。
apt-get dist-upgradeも必要になると思ったのですが、/etc/lsb-releaseを確認したら10.04にアップグレードされていました。(もしかして、最初に失敗したdo-release-upgradeのせいかな?)

$ diff -u sources.list /etc/apt/sources.list | grep ^[-+] | grep -v ^$
--- sources.list        2012-01-14 13:15:15.000000000 +0900
+++ /etc/apt/sources.list       2012-01-14 13:16:02.000000000 +0900
-# deb cdrom:[Ubuntu-Server 9.04 _Jaunty Jackalope_ - Release i386 (20090421.1)]/ jaunty main restricted
+# deb cdrom:[Ubuntu-Server 9.04 _Jaunty Jackalope_ - Release i386 (20090421.1)]/ karmic main restricted
-#deb cdrom:[Ubuntu-Server 9.04 _Jaunty Jackalope_ - Release i386 (20090421.1)]/ jaunty main restricted
+#deb cdrom:[Ubuntu-Server 9.04 _Jaunty Jackalope_ - Release i386 (20090421.1)]/ karmic main restricted
-deb http://old-releases.ubuntu.com/ubuntu/ jaunty main restricted
-deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty main restricted
+deb http://old-releases.ubuntu.com/ubuntu/ karmic main restricted
+deb-src http://old-releases.ubuntu.com/ubuntu/ karmic main restricted
-deb http://old-releases.ubuntu.com/ubuntu/ jaunty-updates main restricted
-deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty-updates main restricted
+deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates main restricted
+deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates main restricted
-deb http://old-releases.ubuntu.com/ubuntu/ jaunty universe
-deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty universe
-deb http://old-releases.ubuntu.com/ubuntu/ jaunty-updates universe
-deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty-updates universe
+deb http://old-releases.ubuntu.com/ubuntu/ karmic universe
+deb-src http://old-releases.ubuntu.com/ubuntu/ karmic universe
+deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates universe
+deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates universe
-deb http://old-releases.ubuntu.com/ubuntu/ jaunty multiverse
-deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty multiverse
-deb http://old-releases.ubuntu.com/ubuntu/ jaunty-updates multiverse
-deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty-updates multiverse
+deb http://old-releases.ubuntu.com/ubuntu/ karmic multiverse
+deb-src http://old-releases.ubuntu.com/ubuntu/ karmic multiverse
+deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates multiverse
+deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates multiverse
-# deb http://jp.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
-# deb-src http://jp.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
+# deb http://jp.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
+# deb-src http://jp.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
-# deb http://archive.canonical.com/ubuntu jaunty partner
-# deb-src http://archive.canonical.com/ubuntu jaunty partner
+# deb http://archive.canonical.com/ubuntu karmic partner
+# deb-src http://archive.canonical.com/ubuntu karmic partner
-deb http://old-releases.ubuntu.com/ubuntu jaunty-security main restricted
-deb-src http://old-releases.ubuntu.com/ubuntu jaunty-security main restricted
-deb http://old-releases.ubuntu.com/ubuntu jaunty-security universe
-deb-src http://old-releases.ubuntu.com/ubuntu jaunty-security universe
-deb http://old-releases.ubuntu.com/ubuntu jaunty-security multiverse
-deb-src http://old-releases.ubuntu.com/ubuntu jaunty-security multiverse
+deb http://old-releases.ubuntu.com/ubuntu karmic-security main restricted
+deb-src http://old-releases.ubuntu.com/ubuntu karmic-security main restricted
+deb http://old-releases.ubuntu.com/ubuntu karmic-security universe
+deb-src http://old-releases.ubuntu.com/ubuntu karmic-security universe
+deb http://old-releases.ubuntu.com/ubuntu karmic-security multiverse
+deb-src http://old-releases.ubuntu.com/ubuntu karmic-security multiverse
$